Hi folks,

I'm trying to set up a new cluster on OES/Linux SP1 with an EMC AX100i
iSCSI disk array. EVMS & NSS are proving rather troublesome. Due to
the requirements of EMC PowerPath 4.4.0, i've had to backrev the kernel
to 2.6.5-7.151-smp.

I've read the documentation 10 times if i've read it once, and i can't
for the life of me get two things working:

1. Software RAID 1 root disks on the internal SATA drives in the
servers. EVMS in the installer doesn't seem to work with this at all,
and i'm not familiar enough with EVMS to work out how to convert after
installation from either mirrored LVM or unmirrored EVMS to mirrored EVMS.

2. Creating NSS pools on the iSCSI devices. Whenever i try to do this
with nssmu, i get the message "20211 Invalid pool name", which of course
doesn't appear anywhere on novell.com or Google. I've tried the
extremely strange pool names of "data", "Data", and "DATA", all with the
same result.

I can manually create partitions and file systems on the iSCSI devices
and mount them no problems, so i don't believe there's any problem with
the disk array or connectivity to it.

So this leads to my questions:

1. Do i really need NSS? Initially, this cluster will only be running
GroupWise 7 and iPrint, which means i shouldn't need to map drives
except for the system administrators. I thought about skipping the
whole NSS deal, but i figure NSS is good insurance for later when we
decide we want to run our file services on this platform, too. :-)

2. Do i really need EVMS on the system drives? I can't *ever* see a
reason for putting NSS file systems on them, so can i get around these
issues by using EVMS with only my iSCSI targets, and leave the root
disks with just software RAID & LVM? I would have thought this
possible, but the documentation seems to assume that OES/Linux servers
will be used for tiny file & print environments where we put data on our
root disks, something us folks with best practices fetishes don't like

3. If the answer to question 2 is no (i.e. that i can use EVMS only
with the data disks), what do i need to do to get EVMS working enough to
support creating NSS on the iSCSI volumes? I've tried adding my
internal drives and the software RAID and LVM volumes on them to the
ignore list in EVMS, but that doesn't seem to produce results that are
any different. I still end up with the same unhelpful error message.

4. Is the old kernel version likely to be causing the problem with
nssmu? Given that the EVMS version is the same on SP1 as SP2
(evms-2.3.3-0.30), i would have thought this unlikely.

Thanks in advance,