Hi all

Running on OES linux SP2. I have a HP DL380, smart 6i scsi controller
with updated firmware and cciss drivers.

Today, I experiences a scsi_mod failure, but very specific. It just
prohibited me to see tapes in my tape drive. I could still see the tape
drives, as well as the SCSI hard disks. But no way to recover, but to
reboot the server.

Messages in /var/log/messages was:
Jun 8 10:35:00 aria kernel: [<f902f630>] scsi_host_alloc+0x300/0x320

Jun 8 16:42:40 aria kernel: scsi: Device offlined - not ready after
error recovery: host 0 channel 0 id 0 lun 0

Messages in CA arcserve brightstor backup was

[06/08/2006-17:09:44 ,-1,0,0,0,-1,2,3,0,0] [Grp -5864(GROUP0)] SCSI
command unexpected failure. errno is 6 (No such device or address)

[06/08/2006-17:09:44 ,-1,0,0,0,-1,2,3,0,0] [Grp -5864(GROUP0)] Drv
<HU85C03031>(0,0,0) Cmd=[TEST UNIT READY] SCSI Error: unknown error.

I tried to re-engage the scsi devices, with no success, unload/reload
the tape, etc... tried unsuccessfully to reload scsi_mod, but as cciss
is using it, i couldn't. So I rebooted the server and it worked again.

Has anyone seen this before?