I've discovered what I think is a bug in OES for Linux. I have been
to reproduce the problem consistently. Here's a brief description:

When logged in to ONLY the OES Linux server's tree, using Client32 4.9
4.9.1, you can map drives to volumes (NSS or exported Linux Reiserfs mount points) and copy files from the workstation to the OES Linux
machine just fine using NCP. When logged into multiple trees, and
doing ANY file I/O to the other tree (copy to or from another server
another tree), you can no longer copy files TO any of the OES Linux
machine's volumes. The message "File or directory is corrupt" is
dieplayed when you try to "paste" files/directories to the OES Linux volume.

OES Linux Box: Lab Machine - Default OES Linux fresh install + NSS.
tried doing the EVMS mod and putting NSS volumes on the same physical

disk AND have tried not doing the EVMS mod and putting NSS volumes on

another seperate physical disk. Makes no difference.

The problem happens exactly the same way if the OES Linux volume is
or if it is just an exported mount point on the Reiserfs file system.
Workstation #1: XP-SP2 with firewall turned off. Client 32 4.9.1
4.9 as well).

Workstation#2: 2003 Server. Client 4.9.1 (tried 4.9 as well).

Lab Tree: Called "OES".
Contains an OES organization.
Server lives in ou=server1.o=oes.
Users live in ou=users.o=oes.
config ojbect lives in o=oes.

admin and the other www users and groups live in o=oes. (Made all
modifications during OES config at initial install basically so that server specific objects went in ou=server1.o=oes and all the common
went in o=oes).

Production Tree:
Name: MWT
eDirectory Version (DS Version 10551.78 on all servers).

3 servers in the tree.
All servers are Netware.
2 Netware 6.5 boxes and 1 netware 5.1 box.
6.5 boxes are SP3.
5.1 box is SP8.

Problem reproduction:
Log in to OES tree only.
Novell Map Network Drive to any volume(s) on the OES Linux machine.

Copy files to/from the workstation and the OES Linux volume(s) without


Log in to MWT tree.
Novell Map Network Drive to any volume on any server in MWT tree.

You can still copy files to/from the OES Linux machine.

Now copy ANYTHING from the MWT tree/server to the workstation.

Can no longer copy files from the workstation to the OES Linux server.

Small copys might work. Large copies might work once. Eventually the

workstation will report "Can't copy, file or directory is corrupt."
that happens, all copy activity to the OES Linux box fails with this message.

Open a DOS Box.

Use NCOPY to copy files from the workstation to the OES Linux machine.

THIS WORKS even though windows explorer copys fail. NCOPY will also
from an MWT server to the OES Linux box directly. DOS COPY or XCOPY
just like Windows Explorer copys do.

Disconnect all mapped drives and log out of all trees.

Log into the OES tree.

Map a drive to the OES Linux box.

Copys to/from the workstation and the OES Linux box work again.

Configure Samba on the OES Linux box to export the same share(s).

Using the SMB protocol (using windows map drive from the windows
neighborhood and NOT the "Novell Connections" folder) works fine, no matter how many trees you're logged in to.

Has anyone else experienced this?


Tim Pearson
Midwestern Telephone, Inc.