I have run into a rather bizarre problem with one of my NetWare
6.5sp3/N65NSS3A servers.

A user called me yesterday evening and reported that most of her files were
missing. I was sceptical, but it was true. I then started copying files
over from backup. I got a message on the first file, indicating that it
already existed.

I believe that all of the files still exist. But I can't see them. I can't
see them from Windows 2000, Linux, or Windows XP. I can't see them from
Remote Manager, or ConsoleOne, or Directory Browser from the console, or,
well, anywhere I've tried. But they're there.

It seems to be a namespace corruption issue. I can see four entries in the
user's home directory in the OS2/NFS namespaces, and only three in the DOS
namespace (i.e. through 'ndir' and 'ncpmount -N os2,nfs' from Linux).

I have the user working from a restored copy of her directory; the old one
is renamed. This could be devastating if it happens everywhere.

I've been reading TIDs...

I've tried NSS /VisibilityRebuild.

NSS /IgnoreSecureTrustee doesn't work with my version of NSS.

Should I try NSS /PoolRebuild?

Should I apply SP4?

Thanks in advance,

Tom Stowell