We solved that problem at our college by creating a new user level in
our Zenworks DLU policy. In the Dynamic Local User policy instead of
choosing one of the default user levels (like User), choose Custom and
New. Select Load and Unload Device Drivers. We called this "User with
load and unload device drivers" and we assign this to all users. It
has virtually solved our USB drive problems. Zenworks works miracles.


On Wed, 13 Jul 2005 12:22:39 GMT, shaun@blackfen.bexley.sch.uk wrote:

>Client OS; Windows 2000 SP4
>Client Ver; 4.83-4.91
>When one of our Staff/Students plugs in a USB Mass storage device (ie a pen
>drive), the Add New Hardware wizards appears as normal - But on the last
>screen of the wizard, an error appears;
>Completed the Found New Hardware Wizard
>(Device Name)
>An Error has occurred during the installation of the device
>Access is denied.
>A screencapture of the error can be found at
>I've tried just about everything I can think of - I've gone through the
>security policy, line-by-line - Nothing I change makes a difference.
>I've created a new security policy from scratch - No difference.
>I've given the everyone group full access to all registry keys - Nothing
>I've given the everyone group full access to every folder on c: - Nothing
>When I log onto a workstaion with Admin access, everything works fine.
>Any help/suggestions would be greatly appreciated.