After updating from NDS 7.62c to eDir 8.7.3 sp9, now I cannot log into the

The error is the general Novell Security Message, " system could not log
you into the network". Looks like I forget my password. On the Pc,I was
running 4.91 sp2 client, upgraded them to 4.91 sp3 last week. I did not
install the NMAS and the two other options on the client. After install,
No problems at all.

On the server today; running NW5.1 sp8 w/ NDS 7.62c, upgraded to eDir
8.7.3 sp9 with no errors. When the NMAS screen came up for install, I only
pick the "NDS" option. The upgrade seems to go well.

This is what I found out so far:

If NMAS was install before on the client, it was there after the upgrade,
if you turn this option off in the clients properties, it logins. If it
was a fresh install of client, NMAS Tab on the login screen won't be there
and it also logins with no problem.

I have tried the new client 4.91 sp4 no luck.
I ran the pkidiag, found 2 problems and fix them.
On the server NMAS.nlm v2.65 Dec 3, 2003 is running
NMAS Client version ( on login tab )

I'm assuming there is something not running the server ?? I not sure.
Any Ideas ??