Well you lot all turned out to be bloody useless. (Note to editor... I
come from a country (Canada) where bloody is a descriptor of your state
after a riding a rodeo bull in a bar... Not a cuss word, as our Brit
friends might feel!) :)

Seriously though, I feel like a goof.

When a Pool is not Sharable for Clustering, you change it to Sharable
by hitting F6 in NSSMU, not in the Pools, volumes or partitions options
where you would expect it, but in the first one, Devices.

Go figure. I want to share a Pool. So I look in volumes (Long shot),
I look in Pools, nope. I look in Partitions, nope.

Why would I look in Devices? Well I guess I should have. Oh well. :)

Geoffrey Carman wrote:
> I have a 2 node shared SCSI Cluster (Dell PE1750's with PERC4DC's in
> Cluster mode. PV220S with 13 146 GB disks, and we just added a second
> PV220S on the second SCSI Channel with 3 X 300GB's).
> NW6.5 Sp2. The way we do a server migrate to the cluster is we make
> the pool in NSSMU (not cluster enabled) then flip the bit in Console1
> nssfsShared to true and make a resource of NEWSERVER.
> We run both in parellel, move the data, then on the weekend, do a
> DNS change of SERVER to OLDSERVER and NEWSERVER to SERVER. I delete the
> NEWSERVER Cluster resource.
> This deletes the clustername_Pool object as well.
> So I use NSSMU to rename the Pool which forces it to create the
> Node1_pool object.
> Then I flip the nssfsShared bit in C1 to True, and create the SERVER
> resource on its existing volumes.
> Well this time, flipping the bit is not working. NSS is not seeing
> it as a sharable pool.
> I cannot do a ALt-F8 in NSSMU to Update NSS (or in C1 using older
> snapins) as it hard locks the server. Seems to be specific to Dell
> hardware, I dunno, don't have enough spare equipment to track it down
> properly. It is repeatable, on all three of our Dell clusters.
> So when I did this the last time, I lost the volume objects as well.
> Which was new and odd. So a DSrepair -a, Advanced, Check Volumes
> recreated the volume objects. Then I added a nssPool attrib with the
> correct Pool in C1, Other tab.
> Then I was able to cluster enable it. All seemed good.
> Well I tried to move it this morning, and the second node won't load
> it, since a POOLS on Node1 shows:
> OZGOODE ACTIVE Multiple Volumes ITS
> Multi use detect OZVOL1
> Where it should have the line Shared, like the below example.
> CAMP DEACTIVE Shared (Clustered
> Multiple Volumes
> Multi use detect
> Any ideas? Already in production, 145GB of data, not on fast enough
> tape to restore from, so that is NOT an option...
> Alt-F8 can be tried, but it almost certainly will still hard lock
> the server. So may not be a plan!
> Both nodes are at PEDGE3.HAM of 7.02c the latest last I looked. Firmware
> on the PERC's is 350O.