I'm testing iPrint on our network (NW6.5 SP2) and have got it working ok.

In order to simplify access I created a Virtual Host in Apache that sets the
DocumentRoot so that whenever anyone goes to iprint.ourcompany.com their
browser goes to \\servername\sys\apache2\htdocs\ippdocs and looks for an
index.html file (I created a iprinters.htm then renamed it to index.html).
That way all a browser needs is to point to "iPrint" and they get a map of
available printers.

(For anyone who doesn't know, a Virtual Host means that you can make the
server answer to any hostname you want, but it will serve web pages from a
different default folder. You create a Virtual Host entry in httpd.conf.)

This works, but.... none of the printers install, the page just seems to
'refresh'. Also if I try to access the maptool.htm page I don't get any
images or lists of available images etc.

I can see some other posts here relate to the same problem, but the
suggested fix is to return to the default DocumentRoot i.e.
sys:\apache2\htdocs. However there should be a way to make this work. I
assume that changing the document root is making path or file references
within the maptool.htm and iprinters.htm invalid, but I can't see any path
references within maptool.htm. The iprinters.html printer url is:


It occured to me that as moiprint.uk.ourcompany is mapping directly to
sys:\apache2\htdocs\ippdocs, then I don't need the "/ipp/" section within
the above url i.e. "moiprint.uk.ourcompany/IPP/iprint1....". But I tried
editing the url path when creating the printer within maptool, making it
"moiprint.uk.ourcompany/IPP/iprint1....", but still get same problem: page
just seems to refresh and no printer is installed.

Somebody must have made this work. Is it worth copying the entire IPPDOCS
structure to elsewhere on the volume (or another volume) and setting a
Virtual Host DocumentRoot to point there?

Any suggestions?

Steve Law