I have solved the issue.

AFTER logging into iManager the broker tries to reaathenticate via LDAP
to upload print drivers. The problem is that unlike iManager the broker
in iManager (probably using the iPrint client) uses the iPrint.conf file
for authentication. Alot of institutions including ours have tailored
this file to point at a different LDAP server and at a specific user
container for iPrint authentication for users (the documentation advises
this). So the broker in iManager passes your admin equivalent id that
you authenticated to iManager with in the first place to the server and
context stated in the iPrint.conf file.
Naturally its not going to find my admin equivalent userid in a normal
users container (thats how our tree is set up) and therefore fails with
the http 401 unauthorized error with iPrint client 4.05 installed.

Client 4.06 is slightly different as it is programmed to ignore the
origional 401 error on failure and try other forms of authentication,
which is where you get the other Winsock and SSL errors from.(I have not
got to the bottom of these failures yet...)

As soon as I changed the context in the iPrint.conf file to include a
context with my admin equivalent id all worked fine with both clients.

see this TID -