We have iPrint working and have been using for a long time without any
problems. We recently received a HP OfficeJet Pro K550 printer to put
on the network. I uploaded the drivers, made the agent and all is good
with that. However, the printer will not print if going through iPrint,
although it says the print was successful. I tried printing to it
directly from the TCP/IP port and it works fine, so its obviously a
iPrint issue. To try to track down where it is getting held up, I paused
output on the iPrint agent and printed to the iPrint printer. The job
stays in the queue and when I resume output is goes out like it prints,
but never gets to the printer. I tried uploading the driver again,
recreating the object, changing the Gateway Port from LPR to RAW - all
with no luck. Also, the manager does not report any problems with the
printer agent.

I have ran into this before when using PCL6 drivers. The fix for that
was to use the PCL5(e) driver and that usually takes care of it. I cant
do that with this printer since HP only releases one driver for the
printer. And, I think its PCL3. Here is a link to the driver:

Any help would be greatly appreciated. Im out of options that I know of
to try.