We run iPrint on a NetWare 6.5 server, with most users printing to iPrint
printers mangaged by this server. I have just gotten iPrint running
successfully on an OES Linux server in our tree and we want this one to
replace the NetWare iPrint server (but not by migrating services from the
NetWare server and no, you do not want to know why). Got iCM working too,
and I'm real happy with it. As soon as all the desktops get the latest
iPrint client (4.20), I'll be able to push printers out to the users one
group at a time (and delete old printers, provided the users have admin
privs on their workstations). Wouldn't it be nice if I could update the
clients remotely, too? That way we wouldn't have to visit all the desktops.

I know, I know, iPrint has an AllowAutoUpdate feature in the iprint.ini
file. I set that to 2 so that it *should* update automatically without user
intervention. The OES iPrint Administration Guide says that the client
checks the default printer first, then updates if necessary. All our
workstations are Win2K, so I imagine that admin rights will be necessary
for update; we certainly had to log in with admin rights to install the
iPrint client the first time around.

But I had to test it, so after editing iprint.ini as above and insuring
that sys:/Apache2/htdocs/ippdocs had the latest nipp*.exe files, I went to
a workstaion that has an iPrint printer as the default and logged in as a
non-privileged user. No update. I ran nipp-s.exe. Interestingly, it ran and
displayed a progress bar and then quit. It didn't update, though. So I
re-booted and logged in as an admin user. Still no auto-update. If I run
nipp-s.exe, though, it updates immediately, replacing the older version
with the newer.

Now, I realize that because many of our users are non-privileged on their
own workstations, we'll probably have to visit them to update the iPrint
client, but I would be very interested in figuring out how to make this
AllowAutoUpdate thing work. Do I need to re-start the NDPSM or anything
else after editing the iprint.ini? The docs provide no guidance that I
could find on this question.

Richard White