I would like to follow up on the postings (see below) from Sean Eckton, and
Joseph Marton about having problems to create printer profiles because the
process just hangs.

We also had this problem where the iManager create printer profile process
would hang forever on the first page of the driver dialog. We would have to
stop the application because it was not responding. Then of course we would
get a Windows error saying the Remote Procedure Call failed, error code

In our case with the Sharp, the trick to get the create (or modify) printer
profile to work was to Cancel on the first Configuration dialog that pops
up. This is the printer properties dialog with all the add-on hardware
options like duplex, finisher bin, memory, hole punch, stapler, etc. that
you get when you right click on an installed printer and select Properties
(of the printer).

If I made any changes on this first dialog of printer configuration, or if
pushed the Auto Configuration button then I was hung. I think what happens
when you make a change on this dialog is that your Windows machine tries to
contact the printer via snmp to verify the option is installed, or in the
case of the Auto Configure button it requests all the installed options via
snmp (this I saw with a packet trace). But because you are really in
iManager talking to a java applet over http you can not contact the printer
directly via snmp so you are hung.

In my case I hit Cancel on this first dialog and the iManager create
profile process continues to load the driver and this brings up a second
dialog with 4 pages of Printing Preferences like paper size, orientation,
copies, resolution, etc. and from this dialog I can make changes and save
the profile.

Then after iPrint has installed the printer on my workstation I can open
printer properties and use the Auto Configure button to pick up all the
hardware options that have been installed on that printer. This works
because it is your workstation talking directly to the printer without an
iManager web server in the middle.

I find the comment interesting from Novell that some drivers are using new
functionality that would require some code re-write to work with iPrint
driver delivery. It would be great if this change could be done so that all
the installed hardware options like extra memory, or duplexer could be
configured in the iManager Printer Profile.


Our environment: NW65sp5, iManger 2.5, Sharp network copier/printer model
AR-M451N, iPrint client 4.16 on XP. Sharp iprinter config: NDPSGW PORT=RAW

>>> On 18.08.06 at 22:21, in message

<cjpFg.311$C61.136@prv-forum2.provo.novell.com>, Sean
Eckton<rseckton@gmail.com> wrote:
> Cassads@wmston.k12.mi.us wrote:
>> When I try and add the xerox 4500 drivers I get an error that says "an
>> internal error has occurred" I have tried the drivers from the cd,
>> downloaded the postscript and pcl5e drivers and they all have the same
>> error .. any ideas ?

> We're having problems with some Xerox drivers, too. I can finally add
> them, or at least it says they are there, but I can't configure a driver
> profile for them. Things just hang. Before moving to NW65SP5 and the
> newest iPrint client (4.20) we had problems adding some Xerox drivers at
> all. Now I think I can add them. Specifically we're seeing this with
> Xerox Phaser 6120 drivers (including the ones that Xerox says are NDPS
> safe).
> When I was at Brainshare in March I talked to the iPrint/NDPS guys and
> they said that some drivers are using some new functionality and it
> isn't compatible with iPrint/NDPS driver delivery. We had that problem
> with some Sharp drivers. I'm not sure what the status of the fix is but
> they said they would have to re-write some code to make it work. The
> same code change needed to happen to support Windows Vista when it comes
> out.
> Sean

>>> On 13.04.06 at 20:10, in message

<pan.2006.> , Joseph
Marton<jmarton@NOSPAMhsemuni.com> wrote:
> On Thu, 13 Apr 2006 15:22:19 +0000, iprintrox wrote:
>> Looks like something might have changed on the client workstation.

> Have you tried another XP machine??
> As a followup... the profile never does get created for the Sharp
> copier.
> I just checked that machine where I was trying to create it, and after
> several hours it was still hanging there. When I cancel out of the
> printer dialog box iPrint returns an error "Remote Procedure Call
> Failed."
> This particular error only appears to happen with this Sharp PS driver.
> I haven't had this exact error on any HP driver, though I am getting
> other
> errors trying to create the profile for the HP LJ2300 PS driver.
> Joe
>>> On 13.04.06 at 17:44, in message

<pan.2006.> , Joseph
Marton<jmarton@NOSPAMhsemuni.com> wrote:
> On Thu, 13 Apr 2006 15:22:19 +0000, iprintrox wrote:
>> Looks like something might have changed on the client workstation.

> Have you tried another XP machine??
> I am having similar problems. I'm trying to create a profile for a
> Sharp
> MX-4501 copier, and it's been about 8 minutes since I've clicked ok on
> the
> printer settings yet the dialog box hasn't gone away. This has happened
> on two machines, and on one I aborted the thing. After aborting on one
> machine that machine now gives me "Error: The printer name is invalid"
> trying to create a profile for that driver. On a third machine I've
> never
> been able to even attempt to configure the profile, I just get the error
> "Error message: The operation completed successfully" even though the
> driver properties never came up. Needless to say the opertion didn't
> complete successfully.
> In addition to this Sharp driver, I keep having similar problems
> attempting to setup profiles for an HP LaserJet 2300. In both cases I'm
> using the latest postscript driver.
> Joe