I am having a problem that I thought someone here might be able to help
me solve.

I run a lab of fedora core 5 machines.
On each I have installed the rpm novell-iprint-xclient-sl-1.0.20051215-2
(installed without error once I had taken down selinux)

As a non root user I navigate to the page set up by our novell
administrators and try to install a printer:

I get a pop up that informs me that the printer is not installed and
asking me if I want to install it.
I click yes
I then get a pop up that asks me to authenticate:
"novel iPrint client"
"Please type your username and password"
Realm: Local iPrint/CUPS user account"

I fill this in and get "incorrect username and/or password"
Please try again.

I have tried using my local username/password and my "novell"
username and password that I use to access my novell shares,
but each to no avail.

Our Novell administrators do not believe that I should get prompted
for any authentication at all.

After bashing against this error for a while I rebuilt one of the
boxes as openSuSE10.1 and did the same install procedure and BAM!
no question about authentication, and the driver installed and I
could print fine!

What do I have to do differently on the fedora box to get this to work?
Or is the client SuSE specific and I should just forget it?

P.S. please let me know what other details I might offer.

Both the fedora and SuSE installs are "vanilla" but if I get this
working on fedora I will want to deploy it on a lab that has user's
home directories mounted via nfs and users have no rights to touch
the local hard drive (apart from /tmp)