Hi all.

I have recently blamed zenworks DLU from failing iPrint authentication,
but now I got that same error in my own workstation and I didn't use DLU.

Every user has uniqueID, iPrint client is 4.20 and Novell client is
4.91SP2. So everything should work. And every now and then it does work.
Then again sometimes it doesn't.

There is one possible cause. I have account in several contexts in tree,
and all of those have same UniqueID because the account name is the same
(which means that it really isn't that "unique"). Could that be the
source of the problem? iPrint tries to authenticate me to the printer
using wrong NDS name?

How to debug? I need help. Any suggestion what to do are welcome.
Network sniffing with ethereal? If that could help I need to know what
to look for.

If this "UniqueID not being unique" is the reason it is enough reason
not to ever use iPrint, because we simply cannot rearrange about 30000
users. That is too much work to do just to get one tiny problem fixed. I
then just need to figure out how to tell HP printers to use A4 instead
of Letter using NDPS.

(NDPS works, and have worked flawlessy since....I can't remember how
long. Only improvement iPrint provides to us is printer profiles.)

Timo Pietilš