NW 6.5 SP6
ZfD 7.0.1 SP1 (hotpatch 2)

Update iPrint client does not occur via iPrint policy

The iPrint client (v4.26) resides in a public r/w accessable UNC path:
This UNC path is set in the policy packages.
The "Re-install client if higher version" is checked in the policy packages,
and I have also incremented the "Version" number.

The folder files present in this iPrint client UNC path are:
nipp-s.exe (also tried renamed to nipp.exe)
The iprint.ini has the AllowAutoUpdate = 2 parameter set.

I've tried to trigger this both via Workstation Policy Packages and in User Policy Packages.
I've tried configuring the policy both on the "General" and "Windows NT - 2000 - XP" tabs.
I've toggled the update schedule for "System startup", "User login" and "User desktop is active".

But still no update distribution happens.
Might this be a bug in ZfD 7.0.1?
It worked fine in ZfD 6.5 SP2...

One more question also:
At some point in time the default placement of the iPrint client has changed in the servers.

Earlier we had the client in:
SYS\Apache2\htdocs\ippdocs (default installed as in TID 297469)
(And automatic update worked fine from this path...)

But now I observe that this path has changed (i don't know when):
Might this change happen during installation of NW 6.5 SP6 or ZfD 7.0.1 SP1?

Due to this change I've tried to utilize a common update path for all OS in the policy packages,
namely the path stated above:

Ideas anyone?
How can I revive the automatic iPrint client update via policies?

- Erik