i have seen lots of people having login problems after deploying the
ZEN-Agent to workstations.

Same as i experienced, i spent last sunday testing and trying and reading
(and cursing a lot).

To the virtual/physical - discussion to this topic: My ZCM Server is W2K3
virtual (ESX) and my workstations are physical AND virtual.

as all of the people at the other threads here everything was configured
right, tested and up-and-running.
LDAP good, DNS good and all that stuff.

But still i had these "cannot login to the network.." message when the
freshly deployed ZEN-Agent wanted to start.

Setting the logs to debug gave me the "An error ocurred during a general
refresh in module: QuickTaskRefresh.Error Message: Object reference not set
to an instance of an object."

Here i went:

* deployed the Agent to XPP SP2 by deployment policy. These were
workstations that had a ZfD7 Agent on them.
=> cannot log in after reboot.

My solution was:
Uninstall the new ZEN agent (which luckily worked without killing the
TCP-Stack as mentioned in other threads)
Reinstall the Agent MANUALLY from https://server/zenworks-setup (the
download-page for the standalones..)

* I was able to reproduce it on virtual as well as physical machines
* A machine where i installed the new Agent manually without uninstalling
the old ZFD7-Agent before got shreddered (my fault maybe).
* Machines i uninstalled ZfD7 and then freshly installed the new Agent
manually worked fine from the start.

==> it seems to me that the deployment via deployment-policy isnt working
that good as it should.


kind regards

Gerd Zobel
The NetWorker GmbH