Hi All,

ZCM 10.0.1 on W2K3 server.

Just completed imaging 16 new (to us) machines and ran into a few things
which I thought I might mention. (I realize we are 10.0.2 currently, but
it seems my box doesn't want to update to that. <g>)

I had initially attempted to take an image of a test machine and ran
into ZISD issues which can occur with datashredded machines. Fotunately,
a fix was available (TID3414734) and I was able to take the image.

Then I set up non-registered device settings, added a hardware rule and
was able to push an image to a "blank" test machine, and everything
worked as expected (although I wound up specifying an IP Address, which
caused a conflict). I subsequently changed this setting for IP
Configuration to "Use DHCP."

The newly imaged machine was named NEW-xxxxx based on my settings.

So I knew it all worked.

I now took an image of an Optiplex 620 which went off without a hitch
and then added another hardware rule in the non-registered device
settings (based on MAC addresses) to detect 4 of the machines I was
cloning. I went away and came back to find all the imaging tasks were
looping on these machines and re-imaging each over and over (which
hadn't happened with the initial test). I then disabled the rule, at
which point the imaging completed on each of the four machines and they
booted up into Win XP. (I subsequently did this for each batch I imaged.)

At the image was applied and the machines rebooted, they all reported
"duplicate names" and I found that the imaging had given all the
computers the same name as the computer which was originally imaged,
rather than the name "NEW-xxxx" based on the earlier settings which were
still in place.

So my two questions:

1. Any way to stop the imaging looping without having to disable or
delete rules?

2. How to ensure that a unique name is assigned during the imaging
process? It is set up that way, but only applied this to the first
machine imaged.

Of the 16 machines imaged, 4 were problematic and after imaging gave
BSOD with UNMOUNTABLE_BOOT_VOLUME error on reboot. These I fixed using
fdisk to delete the partitions and then re-imaging. (All were SATA
drives, fwiw.) Happily no partitioning or formatting was needed to apply
the images.

1 machine refused to image and would simply exit from the PXE boot
process. If I tried to force the imaging using the boot image menu, I
would get "imaging failed with error 91." After hacking around
unsuccessfully, I booted the machine into maintenance mode and looked at
the ZISD info ... interestingly, this machine had apparently not been
shredded like the others, and appeared to have old ZEN data in this area.

I applied the same fix by wiping the area (see referenced TID above) and
then the image was happily applied. Don't know why this would have been
an issue, perhaps because the machine appeared to be from a different
zone? Anyway, wiping the area fixed the problem.

About half of the machines lost keyboard and mouse on first reboot but
most fixed after powering down and back up. A very few of them I
reapplied the image and then they worked fine.

Hope this helps somebody down the line.

Ken McLeod
The Delphian School