Alrighty...I had ifolder 3.6 working on my server running OES2. I had
the data volume on the linux volume. Got all that working, it was great.
So, my boss' wishes were that the data volume be on a NSS volume.

So! I reran the setup (/opt/novell/ifolder3/bin/simias-server-setup) and
changed only the data directory. After doing that, I ran the following
command (found it under the documentations):

rights -f /media/nss/NSSVOL -r rwfcem trustee wwwrun.ou.o.treename

Of course I changed the info to match. I then bounced the Apache2 server
and try to login to the iFolder3 management. I now get the "Your session
has been closed. Please log in" error.

Checking the data directory, I noticed there are less files/directories
than normal. Going into log/Simias.log, I see the error:

[-1239270496] ERROR Simias.Service.Manager - Failed to create Flaim DB.
Simias.CreateException: Failed to create Flaim DB. --->
Simias.SimiasException: Flaim error FERR_IO_ACCESS_DENIED

So I thought maybe rights are don't right. So I went and reran the
command. No errors were returned. I then went through iManager to check
and wwwrun didn't have rights to that volume. So I manually assigned
full rights to that volume for wwwrun, then re-ran the entire setup
again. Still the same errors.

So then I went and changed the owner of my data directory in the NSS
volume over to wwwrun. Reconfigured everything. Still no joy.

Any ideas? I can't think of anything else to try. :(