I have some MAJOR problems with OES2 Linux.

One of the companies I do a bit of work for, recently migrated their Netware 6.5 Servers to OES2 Linux. After only 3 months, they chucked the whole lot out and installed Windows 2003 Servers. When I asked them why, they told me that their experience with OES2 Linux had been a nightmare.

Because of this and to try and keep abreast of the times, I decided to install OES2 so that if another company had problems I could maybe help out.

I started with Novell Products in 1984. Netware 2.0a, which I doubt many of you out there have even heard about, let alone worked with, so I'm not exactly Novell illiterate or computer illiterate either.

I've been battling now for almost three weeks with this - JUST TRYING TO INSTALL IT and still getting nowhere at all.

Maybe someone can tell me what I'm missing here.

I admit I'm not the world's greatest Linux 'Guru' so I decided to follow the Novell Lab Guide which I managed to find some weeks ago but can't find again (good job I downloaded the PDF as finding anything on the latest Novell site is well... a challenge!) It was on Novell Documentation

The box I decided to install it on has had Novell 6.5, Fedora 7 and 8, Red Hat, Windows 2000 and 2003 Server running happily on it in the past. It's a P4, 3.6Ghz Processor, 4GB RAM and a 500GB hard Drive with an Intel Gigabit NIC, so anything going wrong isn't the computer. I have a static business TCP/IP Connection, so we can't blame that either.

So what is going wrong?

  1. My first attempt worked OK up the the stage that I tried to install NDS into a new Tree. After sitting there for a whole night, locked up. I rebooted and started again
  2. I tried to delete the partitions from the previous installation and it let me carry on blindly until I started the actual install. Only then did it give me an error and crash, so I used gdisk to clean the drive and start again.
  3. This time everything was fine until I got to the point of running updates. I ran it 3 times, but all the updates were still marked in red, so it hadn't installed any. I selected all the red items by hand and the update was successful (well so it said) but when I tried to reboot, there were errors everywhere and the NIC no longer worked.
  4. I tried to run the "Other" option from the install DVD to effect a repair, but this time it trashed everything and I couldn't even boot up again. Start Over
  5. This time, I did the install and did NOT mark the red items. I just carried on and completed the install. Now it was fine BUT... I then made the mistake of clicking on the red button in the task bar and telling it to apply updates. BIG MISTAKE... Once again it trashed the entire system. So much for Novell's updates. Start Over
  6. This time when I got to the updates, I selected all of them EXCEPT the prepare to move to SP2 (having seen a warning about this on the forum) - Guess what - IT WORKED. Now I tried to install the iManager plug-ins. 12 hours later it had installed 11 of them and just sat there looking at me making clicking sounds. 8 attempts later, finally installing them one by one it was finished. EUREKA. I have a working installation - Oh yeah - I really should have known better.
  7. I tried to assign the Sample Password Policy to my Users Container, but lo and behold, it wasn't Sample Password Policy but Samba Default Pa I tried to assign it, but can you believe it - click Apply and nothing happens - it just stares at you.
  8. I managed to install iPrint, iFolder, LUM, SLP, everything in the Lab Guide BUT - what I also needed was a Virtual Host on Apache. So I followed the documentation, copied the vhosts.template to myvhost.conf, made the changes to the script and tried to restart Apache, will it start? - NO - Why not? Well the script is looking for mod_php4, but hang on, isn't mod_php4 dead isn't it mod_php5? Well whatever it is, it isn't there, nor will Yast install it, nor can I download it because no matter what you try to install on OES2 has dependency errors - so much for Open Source!

Compared to installing a working copy of OES2, installing Netware 2.0a with it's 36 floppy disks and spending 2 or 3 days compsurfing the hard drives, was a piece of cake AND IT WORKED.

So far after 3 weeks of battling, I still haven't achieved my goal. I have a working OES2 Server, but no Virtual Host and no PHP and I wouldn't mind betting money that MySQL doesn't have PHP support built in and that you can't recompile it WITH PHP support either! Oh and I almost forgot, no Password Policy either!

Can anyone come up with any ideas that vindicate this release of OES2? So far, I have to say that if I were running a big company, I would either install Windows or Red Hat. I don't like Windows, BUT I CAN AT LEAST INSTALL IT FIRST TIME and even though it crashes with monotonous regularity when it UP, it works!

I've been a loyal supporter of Novell since 1984, but I'm starting to think I'm trying to ride a dying horse!