I have a question regarding creating contacts. I am using createItemRequest
to do this. As long as I leave off the email addresses, the contact is
created successfully.

However, if I add something such as demo@test.com, then the soap response
returns the error 53523 (Domain Not Found).

If I put in a valid address on the post office (in this case
myuser.po1.gwdom1) then it saves fine.

My question is, what do I need to do to allow addresses such as
demo@test.com to be used?

Note: In webAccess and the Groupwise 7 client, I can put in any addresses I
want and it saves fine.

Another Note: If I do a getItemRequest to get an existing contact (one added
with Groupwise 7 client and with 2 addresses like the demo@test.com one) ...
I just turn around immediately and call createItemRequest with that Contact
item that was returned - I still get the same error.

The same occurs with modifyItemRequest if I use email addresses like

It appears using soap, that gw is doing some kind of validation on the
addresses? But in the client and webaccess, it is not? How do I allow soap
to do this?

Thanks in advance
Matt Fardig