I'm trying to install a new SLES10sp2 / OES2sp1 server into an existing tree. At the point where the install attempts to configure eDir I get a ndsconfig error with the following details...

Logging into the tree as "FDN of admin account". Please wait...
ERROR -669: Unable to login - Authentication failed
ERROR -l: Setup for NDS installation failed.
Please make certain that you have provided the complete server and admin contexts.

ERROR: /opt/novell/eDirectory/bin/ndsconfig return value = 59.

On the replica server that I am using to install with I get the following error in dstrace...

14:17:22 A85F3BA0 LDAP: DoBind on connection 0xd45ca00
14:17:22 A85F3BA0 LDAP: Bind name:cn=admin,ou=services,o=vault, version:3, authentication:simple
14:17:22 A85F3BA0 Auth: [00008024] <.admin.services.vault.IDM-VAULT.> EmuVerifyPassword returned error OS error of some sort (-255), conn: 26

I've verified that the user's credentials are correct and that it has proper rights to the tree. The tree is healthy. I've tried to use two different replica servers with the exact same error.

Any ideas?