I recently installed a new Mobility server in our DMZ. Everything with the install went smoothly, except I am now unable to register / sync a phone (Motorola Droid) with the server. Here is the error I am getting:

"Unable to open connection to server"

Here are the different combinations of fields I've populated, and all give me the same error:

Email address: Tried GW display name, NDS display name, NDS fully qualified name. (all with a "@domain.com" after them.

Password: Using NDS password.

Domain\Username: (This field is not used, right?)

Server: Using IP address of server.

SSL: Is selected.

The user has been added to the admin webpage. I can login to the webpage as this user (it is also the admin user) and I've changed the application user name to match the GW display name (In our environment the NDS is "lastname first initial" and the GW display name is "firstname space lastname")

Everything else on the server looks good. Trusted app key / LDAP is fine. Firewall is disabled (temporarily). Proxy is disabled. All services are running. Not sure what else it could be. Are there any log files I could look at for more clues? Thanks,