I am running OES 2 fully patched, running iPrint. I login through iManager with full access to try to manage a printer and get an error:

Exception reading printer control
java.net.SocketException: Unexpected end of file from server
IPP Error: 0x40001

I have been wracking my brains and searching Google for an answer.

I have tried the routine things: restart server, restart apache, restart tomcat5. I have also tried the steps outlined here:

IPP Error: 0x40001 creating or managing iPrint objects

In these steps my results were:

Step1 [echo | openssl s_client -connect]
Step1 result [Verify return code:21 (unable to verify the first certificate)

I thought maybe a CA error but in the notes directly beneath these steps the post mentioned that this is not a direct indication of a certificate problem. That SSL connection was successful.

I then looked at the /etc/apache2/listen.conf file to try and add a statement equivalent to the following:

Listen 443

I noticed that this was already there.

My suspicion of the security certs led me to look at the two yast entries for certificates and under the Common Server Certificate I see under the heading of "Validity" it says "not after: jan 21" - this stopped working after that date.

I might be way off on the wrong track here but if anybody has seen this before or has any steps I can try I would definitely appreciate your help.