I followed the documentation in Zenworks 11 System Administration Reference section 31.7.2 Essentially 4 steps:
1. stop services
2. move the database
3. change /etc/opt/novell/zenworks/datamodel/zdm.xml
4. start services

Here's the log of what happened when I started services; this is actually the second time I tried because the errors kept pointing me to a database problem:

/etc/opt/novell/zenworks/datamodel # /opt/novell/zenworks/bin/novell-zenworks-configure -c Start

ZENworks 11.0 Configuration Utility

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~

Key not found: ZEN_DATABASE

For each prompt presented, press 'enter' to accept the (default) value, type
'back' to return to the previous action, or type 'quit' to exit.

__________________________________________________ _____________________
Specify the daemons you wish to control and what action to perform:
1-[X] Novell ZENworks Service Monitor
3-[X] Novell ZENworks Management Agent
4-[X] Novell ZENworks Server
5-[X] Novell ZENworks Loader
6-[X] CASA Authentication Token Service
7-[X] Novell ZENworks Preboot Service
8-[X] Novell ZENworks Preboot Policy Service
9-[X] Novell TFTP Service
10-[ ] Novell Proxy DHCP Service
11-(*) Start
12-( ) Stop
13-( ) Restart

Enter a comma separated list of indices (1 to 13) to toggle the selection
states. Pressing the Enter key without entering a number finalizes your

INFO: Novell ZENworks Service Monitor started
Key not found: ZEN_DATABASE
SEVERE: There was an error starting ZEN_DATABASE. iAnywhere Solutions, Inc.
One Sybase Drive, Dublin, CA 94568, USA
Copyright (c) 2001-2007, iAnywhere Solutions, Inc. Portions copyright (c)
1988-2007, Sybase, Inc. All rights preserved. All unpublished rights reserved.

ZENworks Database configuration file
[/etc/opt/novell/zenworks/zenworks_database.conf] not found - Aborting..failed

SEVERE: There was an error starting Novell ZENworks Management Agent. ZENworks
Adaptive Agent is already running

INFO: Novell ZENworks Server started
INFO: Novell ZENworks Loader started
SEVERE: There was an error starting CASA Authentication Token Service.
Starting casa_atsd.....failed

INFO: Novell ZENworks Preboot Service started
INFO: Novell ZENworks Preboot Policy Service started
INFO: Novell TFTP Service started

The casa_atsd failure was due to there being a pid file at /var/lib/CASA/authtoken/svc. I deleted that and "/etc/init.d/casa_atsd start" worked.

But all those database errors: key not found, file not found. These made me think the move to the new Oracle database had failed. But everyone was using their tools fine. netstat showed connections to the correct database server on the correct port. So I think it worked but I've spent all day trying to convince myself. What are your thoughts? Is there still a problem?