I've been running a Zenworks server for a couple of months, now, for our imaging needs (we were using Norton Ghost, before). Last week, I applied a pre-boot image to two of our labs and ran into a problem. After the imaging process and a reboot, every device gets stuck at this error message:

Error loading operating system
(in fact, the message is "Erreur lors du chargement du systeme d'exploitati", we're running a french version of Windows XP)

Two weeks before and even earlier, I applied pre-boot bundles to all of our labs and everything worked without problems. I haven't touched the images since, the only change I made is that I upgraded from ZCM 11.1 to ZCM 11 SP2. I've tried all of our bundles and none of them works, after applying it to a device. Could the problem come from something in SP2?

I've read in another thread of a similar problem, trying TID 3414734 didn't do much to help either.

Is this a known issue? Is a fix on the way? What do I do now? I'm stuck and I don't know what to do next...