I am seeing laptops that are suddenly becoming unavailable and nothing ZCM related is not working. The service is not running and will not stop or start. I am seeing the following in 2 of my log file.

[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [CertManager] [] [Checking if host address 10.16.231.91 maps to cert subject zcmpri1.frederick.k12.va.us] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [CertManager] [] [Checking if host address 10.16.231.91 maps to cert subject zcmpri1.frederick.k12.va.us, alt host names are (zcmpri1.frederick.k12.va.us,10.16.231.91,zcmpri1)] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan-ping] [] [ Using uri: https://10.16.231.91/] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Marking location zcmpri1.frederick.k12.va.us Good at the request of module registration] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [ Setting location name zcmpri1.frederick.k12.va.us to status Good] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Marking location 10.16.231.91 Good at the request of module registration] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [ Setting location name 10.16.231.91 to status Good] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Marking location https://10.16.231.91/ Good at the request of module registration] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [ Setting location name https://10.16.231.91/ to status Good] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [ Setting location https://10.16.231.91/, IP address 10.16.231.91, and host zcmpri1.frederick.k12.va.us to status: Good] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [ Using location: https://10.16.231.91/, status: Good] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [FindFirstContent() returning https://10.16.231.91/] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [(Thread 12) GetObject(deviceResponse:Registration, UserContext{_LocalId=SYSTEM; _RemoteId=6b6949724694004bb565281558204c17}) called] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [Process ZenworksWindowsService acquired the access mutex for object cache ] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [Released the access mutex for object cache] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [(Thread 12) GetObject returning C:\Program Files (x86)\Novell\ZENworks\cache\zmd\ZenCache\891140cc-5574-4fa1-aab6-6511a93119c0 in 2 ms] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [================================================== =====] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Adapter Name: {7B65660A-D6EF-4819-957A-8C9618C9C15C}] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Description : Microsoft Virtual WiFi Miniport Adapter #2] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Gateway : 0.0.0.0] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [IP Address : 0.0.0.0] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [================================================== =====] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [================================================== =====] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Adapter Name: {46844511-0D3B-40BF-854D-D21E752A4E41}] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Description : Microsoft Virtual WiFi Miniport Adapter] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [DHCP Server : ] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Gateway : 0.0.0.0] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [IP Address : 0.0.0.0] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [================================================== =====] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [================================================== =====] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Adapter Name: {2F0D6A07-808B-4439-9370-54233DBA55E4}] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Description : Intel(R) Centrino(R) Advanced-N 6205] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [DHCP Server : 10.16.231.244] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Gateway : 10.20.1.1] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [IP Address : 10.20.250.114] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [================================================== =====] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [================================================== =====] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Adapter Name: {80717D63-9ABB-4098-93E4-5E7CE99BF382}] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Description : Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [DHCP Server : ] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Gateway : 0.0.0.0] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [IP Address : 0.0.0.0] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [================================================== =====] [] []
[DEBUG] [10/10/2012 07:32:24.707] [1700] [ZenworksWindowsService] [12] [] [RegistrationManager] [] [DNS for address: 10.20.250.114 is SHS-SCIENCE-10.frederick.k12.va.us] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [(Thread 12) GetObject(ZEN_DeviceSerialNumber, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [Process ZenworksWindowsService acquired the access mutex for object cache ] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [Released the access mutex for object cache] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [(Thread 12) GetObject returning C:\Program Files (x86)\Novell\ZENworks\cache\zmd\ZenCache\8a96d297-a65a-40a6-8612-f4168fd8635c in 3 ms] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [RegistrationModule::SerialNumberInfo] [] [Retrieved cached serial Number : C5NXAS64811021D] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [(Thread 12) GetObject(ZEN_DeviceSerialNumber, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [Process ZenworksWindowsService acquired the access mutex for object cache ] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [Released the access mutex for object cache] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [(Thread 12) GetObject returning C:\Program Files (x86)\Novell\ZENworks\cache\zmd\ZenCache\8a96d297-a65a-40a6-8612-f4168fd8635c in 2 ms] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [RegistrationModule::SerialNumberInfo] [] [Retrieved cached serial Number : C5NXAS64811021D] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [RegistrationManager] [] [Device SerialNumber is C5NXAS64811021D] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [(Thread 12) GetObject(PROXY_OVERRIDE, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [proxy_override(public) doesn't exist in memory key cache] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [(Thread 12) GetObject returning <not cached> in 0 ms] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [(Thread 12) GetObject(PROXY_DEFAULT, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [proxy_default(public) doesn't exist in memory key cache] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenCache] [] [(Thread 12) GetObject returning <not cached> in 0 ms] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenService] [] [Registering device] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenService] [] [OS: windows7-pro-sp1-x64, Locale: en-US] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ZenService] [] [Version of ZENworks Agent and Components :<?xml version="1.0" encoding="utf-16"?><AgentDescriptor xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="http://www.novell.com/zenworks/webservice/registration"><Version>11.2.1.10274 Monthly Update 2</Version><Copyright>Copyright Novell, Inc. 2012</Copyright><Product>ZENworks Adaptive Agent</Product><Modules><ModuleDescriptor><Name>Image Management</Name><Company>Novell, Inc.</Company><Product>ZENworks Adaptive Agent</Product><Copyright>Copyright Novell, Inc. 2012</Copyright><Version>11.2.1.6353</Version></ModuleDescriptor><ModuleDescriptor><Name>User Management</Name><Company>Novell, Inc.</Company><Product>ZENworks Adaptive Agent</Product><Copyright>Copyright Novell, Inc. 2012</Copyright><Version>11.2.1.9634</Version></ModuleDescriptor></Modules></AgentDescriptor>] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [RegistrationManager] [] [ZenException during RegisterDevice after IP address change. Service Error. code: -1, message: Invalid device port: 0] [] []
[DEBUG] [10/10/2012 07:32:24.722] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Waiting for Address Up / Down Notification] [] []
[DEBUG] [10/10/2012 07:32:24.738] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [NotifyAddrChange() returned 997] [] []
[DEBUG] [10/10/2012 07:32:24.738] [1700] [ZenworksWindowsService] [12] [] [ConnectMan] [] [Waiting for notification of address up / address down.] [] []
[DEBUG] [10/10/2012 07:32:25.144] [1700] [ZenworksWindowsService] [6] [] [WinProxy] [] [Registering to CommandLine Manager 10/10/2012 7:32:25 AM] [] []
[DEBUG] [10/10/2012 07:32:25.159] [1700] [ZenworksWindowsService] [6] [] [WinProxy] [] [Registering to ZENworks Icon 10/10/2012 7:32:25 AM] [] []
[DEBUG] [10/10/2012 07:32:25.159] [1700] [ZenworksWindowsService] [6] [] [WinProxy] [] [Registered Successfully 10/10/2012 7:32:25 AM] [] []
[DEBUG] [10/10/2012 07:32:25.159] [1700] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Start() for module com.novell.zenworks.module.winproxy returned successfully] [] []
[DEBUG] [10/10/2012 07:32:25.159] [1700] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Before calling Initialize() for module com.novell.zenworks.module.systemupdatemodule at path C:\Program Files (x86)\Novell\ZENworks\bin\modules\SystemUpdate.dll] [] []
[DEBUG] [10/10/2012 07:32:25.159] [1700] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Initialize() for module com.novell.zenworks.module.systemupdatemodule returned successfully] [] []
[DEBUG] [10/10/2012 07:32:25.159] [1700] [ZenworksWindowsService] [6] [] [ModuleLoader] [] [Before calling Start() for module com.novell.zenworks.module.systemupdatemodule at path C:\Program Files (x86)\Novell\ZENworks\bin\modules\SystemUpdate.dll] [] []
[DEBUG] [10/10/2012 07:32:25.175] [1700] [ZenworksWindowsService] [6] [] [ZenCache] [] [(Thread 6) GetObject(system.update.last.report.time, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] []
[DEBUG] [10/10/2012 07:32:25.190] [1700] [ZenworksWindowsService] [6] [] [ZenCache] [] [Process ZenworksWindowsService acquired the access mutex for object cache ] [] []

Any suggestions as of why this could be happening?