I *think* I know the answer to my problem. But before I do, I thought I'd ask the collective wisdom on whether there was an easier way.

Long established GW system dating from 5.1

  • Orginally one domain with mta and PO.
  • Added Gwia onto same domain and server.
  • As some point moved the gwia onto it own server but kept in the same domain as PO.
  • Second/Primary domain added for resilience.

Current Setup:
  • Primary Domain running on Netware 6.5 server with no other GW components
  • mail Domain running on NW6.5 server with PO
  • GWIA on seperate NW 6.5 server along with WebAcc agent


Moving GW mail domain and PO to a new OES server. Followed the instructions to move the data and then install the GW components.
MTA and PO loaded (after a few gotchas) and internal email worked fine.
Outbound email via GWIA worked
Inbound email only worked with agent was started, but the files stayed in WPCSIN.
Newer inbound email just collected behind the existing email.
Restarting the GWIA reprocessed the whole of WPCSIN so email was duplicated and sent and so on.
Looking at the files in WPCSIN the names were no longer in 8.3 format, as the 'dot' had been replaced with a 'square' character.

All GW components are at 8.2 HP3
The GWIA and MTA etc all communicate via TCP/IP not direct.

Now my guess is that now the GWIA is still on Netware but the domain and PO are on OES there is an issue with these being on separate servers and the correct resolution is to create a new domain for GWIA and create a new GWIA which services the email domain.

My question is, is there any quick fix which would sort out the issue of the corrupt file names going into WPCSIN or is a GW reconfgure the only solution.