We've had a few instances while upgrading from 10.3.4 to 11.2(.2) where workstations fail during the agent installation (or manually rebooted half way by user)
All of these instances have ended in re-imaging the device because it just wasn't possible to get Zenworks going with everything we tried, but now I have a laptop with the same problem but we can't image it(no proper image).

So far I've tried uninstalling the agent + casa, running the agentcleanup util and manually going through the registry looking for ZCM related keys.
Every time the new agent is installed it fails at setup.exe at the very end.

The last 2 event log entries are:
ZENPreAgent.VerifiableURI.openPackageStream(Boolea n useLocalFile)
proxy not enabled
ZENPreAgent.VerifiableURI._retrieve(Boolean shouldVerify, Boolean keepOpen, Boolean useLocalFile)
Proxy address:

The only thing the failing computers have in common is that they all had 10.3.4 installed before, this last laptop has not been on the network for too long and still had 10.3.4 while Zenworks already finished its update round. The device had been removed for inactivity.

Any ideas ?