Hi

Having a tough time getting anywhere with the Free/Busy requests. Can someone spot where we're going wrong with this? $gwclient2 is a valid session and works for any other call and we're re-using the same libs/classes as PTGv0.7.2. The SOAP request (which looks a little odd starting at param0) and the response is appended below.

/* snippet */
$user1 = new NameAndEmail();
$user1->email = 'janedoe@somewhere.com';
$user1->displayName = 'Jane Doe';
$user1->uuid='8528BE20-164E-0000-BC98-5E00DD007000';
$userlist = new FreeBusyUserList();
$userlist->user = $user1;

$sfb = new startFreeBusySessionRequest();
$sfb->users = $userlist;
$sfb->startDate = '2013-02-15T14:13:18-05:00';
$sfb->endDate = '2013-02-15T15:13:18-05:00';

$startResp = $gwclient2->startFreeBusySessionRequest($sfb);



<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns1="http://schemas.novell.com/2005/01/GroupWise/groupwise.wsdl" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:ns2="http://schemas.novell.com/2005/01/GroupWise/types" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
<SOAP-ENV:Header>
<ns2:session>qiknJqZLE3s9NKEI</ns2:session>
</SOAP-ENV:Header>
<SOAP-ENV:Body>
<ns1:startFreeBusySessionRequest>
<param0 xsi:type="SOAP-ENC:Struct">
<users xsi:type="SOAP-ENC:Struct">
<user xsi:type="SOAP-ENC:Struct">
<displayName xsi:type="xsd:string">Jane Doe</displayName>
<email xsi:type="xsd:string">janedoe@somewhere.com</email>
<uuid xsi:type="xsd:string">8528BE20-164E-0000-BC98-5E00DD007000</uuid>
</user>
</users>
<startDate xsi:type="xsd:string">2013-02-15T14:13:18-05:00</startDate>
<endDate xsi:type="xsd:string">2013-02-15T15:13:18-05:00</endDate>
</param0>
</ns1:startFreeBusySessionRequest>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>


<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ns1="http://schemas.novell.com/2005/01/GroupWise/groupwise.wsdl" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
<SOAP-ENV:Header/>
<SOAP-ENV:Body>
<startFreeBusySessionResponse xmlns:gwt="http://schemas.novell.com/2005/01/GroupWise/types">
<status>
<code>53285</code>
<description>No users specified</description>
</status>
</startFreeBusySessionResponse>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>