I upgraded our datasync server today from 1.2.4 to 1.2.5 and it broke it badly.
The server is running on a VMware VM and is based on SLES11sp2 64bit.

After upgrading the RPM's through the update channel all the devices had disappeared from the mobility connector.
In the mobility connector log this shows up "Fatal Error - no devices exist for user".
No other errors in the log I could see.

Reregistering devices failed as well.

Fortunately I made a VMware snapshot before the upgrade so I could easily go back, but I do want to upgrade to 1.2.5.

Any suggestions where to look when I try again?