I'm having a problem with one user, in a corporate environment of several thousand. Workstations are imaged and Zenworks is used, so that virtually all workstations are configured the same. The Windows 7 64-bit workstations currently have Client2 SP2 installed, and there are still many Novell servers in use, and the Novell login script configuring drive mapping, although the company is in the midst of a migration to AD/Windows.

One user was having login-script-window issues after a particular server was migrated Netware-to-Windows. This was finally tracked down to a "map del" command that was referring to a drive that hadn't been mapped; therefore, the error was keeping the login script from closing.

Now the issue is fixed, and the login script shows no errors in results when she logs in, but it still doesn't close.

I have checked the gui setting for "close automatically" and it is checkmarked. I have checked the registry at HKLM|Software|Novell|Login|System|Profiles|Default |Tab2 -- there is only the Default profile -- and all three of Close Results, Display Results, and Login Script are set to 1, just as they are for everyone else. I removed a temporary local policy that was disabling login script synchronous execution; there are now no local policies applying, and the domain-based GPO (for all users/workstations) is to run login scripts sync ... but everyone else's results window closes.

The script completes all commands and gets down to the transfer to the personal login script, but just doesn't close. The personal login script is identical to mine, i.e. does nothing but transfer to a batch file (i.e. @start32) but mine, and everyone else's, closes.

So what possible reason is there that the script doesn't close for this one user? Without any errors, it should close automatically.

Thanks for any tips, hints, ideas.