I developed some code using the LDAP libraries for Java, which is
hooking into the Events callback. It was working fine against eDir 8.8
(SLES 10, RPM version 8.8-1, DS Version 20112.21)

However it doesn't work against eDir 8.8.1 SP1 (SLES 10, RPM version
8.8.1-7 and NDSRepair -T says the DS Version is 20114.24). I've tried it
against two separate installations with this version, with the same result.

The error I get occurs as soon as the libraries try to catch an event.
An exception is thrown within the library code, and although I see the
error, it's never thrown out to my code. The error is:

at com.novell.ldap.LDAPResponse.getResultCode(Unknown Source)
at com.novell.ldap.LDAPResponse.getResultException(Un known Source)
at com.novell.ldap.LDAPResponse.chkResultCode(Unknown Source)
com.novell.ldap.events.LDAPEventSource$EventsGener ator.processmessage(Unknown
com.novell.ldap.events.LDAPEventSource$EventsGener ator.run(Unknown Source)

I just checked, and the same thing happens with the sample
EdirEventsCallback.java provided as one of the samples.

Is this a bug, or is it just a problem with this specific version of
eDirectory? The newer versions that exhibit the problem are someone
elses' servers, so I haven't been able to apply any later patches to check.