We've been running NSD 7.0.3 Appliance for a long time with eDirectory as the user source. We now need to change the user source from eDirectory to Active Directory.
I'm attempting to add a User Source, (Setup -> LDAP, Select Active Directory).

It asks for 'NT Domain' and 'Win2000 Domain'. I enter 'MBBC' and 'ad.mbbc.qld.edu.au' which I believe are correct for what is required (our domain servers are WIn 2012 R2).
When I enter my 'Username', I have tried 'myusername', 'cn=myusername', cn=myusername,ou=staff,ou=user,dc=ad,dc=...'

I've tried 'Users Node' as ..

And regardless I what I try, I get :
"Failed to connect to the Active Directory Server, for the following reasons:
2K: Invalid credentials (check username/password).
NT: Invalid credentials (check username/password). "

Not sure if it's relevant, but the NSD groups are in a different OU to the Users.

I've read the docs and they are vague, to be polite.. Does anyone have AD in their environment with NSD, who might be able to assist me? Or which log files might tell me what is actually failing authentication?