I'm have installed a trial iPrint 2.1 appliance and am having troubles with Chromebook printing.

I've installed the extensions and when I use my personal account printing works fine. However if I try and use and account in your Google Apps domain I get the error in the following screenshot

Click image for larger version. 

Name:	Screenshot 2016-08-04 at 11.01.26.png 
Views:	35 
Size:	48.1 KB 
ID:	5573

Now this is when connected to the same wifi network using the same credentials so no network ACLs are different, the only difference is the user signed in to the chromebook. I have even created a new Google Apps for Education domain so that any domain or chrome policies were their defaults and this still occurs. I have also tried different Chromebooks, some connected to the management domain and some not, the result is the same.

There is unfortunately very little documentation for the Chromebook printing but I am hoping someone else has tried to use this and found the same issue and hopefully a solution. If someone could give me some guides hon how to start troubleshooting this it would also be appreciated, the extension appears to be a black box with no debug options I can see.