(ZCM 11.4.3, Single primary server appliance)

I have my Primary updated to 11.4.3 and have done an update of the Windows agent from the ZCC via the System updates tab for a couple WS successfully. Now I want to create an executable from the ZENworks Tools page using the Default Agent (x86_64_Complete) with an install type of 'Standalone' (NOT 'Standalone (.NET 4.0 required)).

I create a new package that I call ZCM_11.4.3_Agent and save it. Now when I run that package on a WS that already has the 11.4.2 agent on it, it comes back with the error: "ZENworks Adaptive Agent already exists on the device" in a CMD window and wants me to press Return. I had followed the same process before to create an 11.4.2 ZCM agent to upgrade WS that had the 11.4.1 agent installed and when I ran it, it would upgrade the 11.4.1 agent to 11.4.2 with no problems.

I looked at the startup switches for the ZCM agent and have tried both the /q for quiet and /U to force an uninstall of the old agent. Neither helped; I got the same message.

I CAN uninstall the 11.4.2 agent then run the "ZCM_11.4.3_Agent" on the WS when no other agent is installed and it will install the 11.4.3 agent correctly so the installation package is good.

What can I do to get the 11.4.3 agent to install over the 11.4.2? I want to put this in a bundle to push out but I can't even get it to run by itself right now.