{First of all I am not sure if this should be posted in this forum or the Reporting - BOE or Inventory forums. I am running the ZCM 11.4.3 appliance with 11.4.3 agents installed on WS. Let me know if I should put this in a different forum.)

I have updated most of the agents in our office to the 11.4.3 version and wrote a custom report in the ZCC - Reports - Inventory custom reports location that basically reports any WS where the ZENworks Adaptive Agent Product Version is not = I get some results which show that these WS have, say, the agent. However, if I go to that WS in the ZCC and open its properties, it shows that it DOES have the agent installed.

Following Craig's advice from another thread I created a bundle that deletes the .XML files in the C:\Program Files (x86)\Novell\ZENworks\work\inventory directory on the WS, then I run "zac inv -f scannow", wait until it's done then run "zac sts rollup", wait until it's done then run a "zac refresh". This doesn't always seem to push the new inventory up to the single primary server appliance right away, even if I wait 20 or 30 seconds before I run the "zac refresh". I can monitor the /var/opt/novell/zenworks/collection/inventory directory on the server and don't see the file being pushed up. If I go to the WS and locally do a zac refresh from the icon in the system tray, it seems to push up the inventory. Why won't the bundle do that?

One WS that I forced a new inventory run on last week and this week when I run the above report, I STILL see that the report says the WS has the 11.4.2 agent while the ZCC properties for the WS shows it has the 11.4.3 agent! Why is that? I have inventory scans set to run every day.

How long after the inventory file is sent up to the appliance should that data appear in a custom report?

On the server under the /var/opt/novell/zenworks/collection/inventory there are 3 directories: success, failure and waiting. The docs talk about the success and failure directories but don't mention anything about the waiting directory. What is it for?

BTW, I show only 2 xml files in the 'waiting' dir, both with multiple tildes after them, like:
1491333774-ca45c5aa269b13fccab6c4472dc6035a-0-017-delta~1~1~1~1~1~1~1.xml and have timestamps of before today.
I have 2 files in the 'failure' subdir and all the rest are in the 'success' subdir.

For the one WS I mention above, if I look on the server in the .../inventory/success dir, I see 3 files with today's timestamp that have that WS name in them. The latest with a timestamp of a couple hours ago so that data on the server is current.