After upgrading from Zenworks 2017 to Zenworks Update 1, I am getting the following error when trying to access System Services and Online Update:

RPC Communication Error
An error occurred while communicating with the server, would you like to see the details.

Clicking yes displays: erviceException: Type '' was not assignable to '' and did not have a custom field serializer. For security purposes, this type will not be deserialized.

Zenworks 2017 was fully functional prior to updating to Update 1. There were no errors accessing Appliance Configuration settings. The upgrade itself went flawless without an errors from the update monitoring link. I first logged in to ZCC where everything looked fine. Then, I tried to do a PXE boot which failed, so I thought I should make sure the dhcp proxy service was running. After getting the RPC Communication Error after clicking System Services, I thought perhaps there was an update to fix this so I tried Online Update which returned the same error.

I'm not finding a fix for this on the forum nor KBs so I'm reaching out to you all for help.