Been a while since we had applied a PRU to our zone, so attempted to update with May 2018 PRU and now receiving the following message on 75% of our managed devices (and rising), KB validation failed, inventory scan can't be started (Message ID: KB validation failed, inventory scan can't be started). Currently running Zenworks 2017 appliance with update 2a applied.

The lone error entry in the log on the client while set in debug mode: [ERROR] [05/23/2018 17:06:05.784] [3196] [ZenworksWindowsService] [81] [olivj] [InventoryManager] [InventoryManager.KBValidationFailed] [KB validation failed, inventory scan can't be started] [] [] [] [ZENworks Agent]

Receiving the message on a mixed bag of devices we have in our zone from our older Windows 7 machines all the way up to and including our latest imaged Windows 10 version 1803 machines with inconsistent behavior viewed as well. A couple devices that were being watched failed repeatedly, worked once (no user intervention was done), then failed repeatedly once again. Scans set to run on boot or a refresh of the device (usually once an hour). Same message if running the inventory scan from the server or scan now from the client. Removal and re-installation of agent also has no effect as well as a reboot of both server and clients.

Knowledge Base Status in Asset Inventory tab shows the following, The date of the most recently applied PRU is May 1, 2018 12:00:00 AM (version 3.6.A.16). The KBs were last merged on May 23, 2018 11:45:53 AM..

Steps followed to deploy PRU:
  1. Download Update.
  2. Authorize Update.
  3. Deploy PRU Now.

What is the cause of the message? Any suggestions or pointers to the proper support document or thread would be appreciated.