Just in case somebody stumbles accross this too:

System Update from 11.4.3 to 2017.3 on OES 2018 failed. It turned out that rpm tried to call systemctl disable but failed; this was because of an old link - deleting this solved the problem:

from the rpm log:

+ /usr/bin/systemctl disable novell-zislnx.service
Failed to execute operation: No such file or directory
D: %preun(novell-zenworks-zislnx-17.3.0-1265.x86_64): waitpid(27671) rc 27671 status 100
error: %preun(novell-zenworks-zislnx-17.3.0-1265.x86_64) scriptlet failed, exit status 1
error: novell-zenworks-zislnx-17.3.0-1265.x86_64: erase failed

:~ # systemctl disable novell-zislnx.service
Failed to execute operation: No such file or directory

:~ # systemctl enable novell-zislnx.service
Failed to execute operation: Too many levels of symbolic links

:~ # find / -xdev -name novell-zislnx.service
/etc/systemd/system/novell-zislnx.service
/etc/systemd/system/multi-user.target.wants/novell-zislnx.service
/usr/lib/systemd/system/novell-zislnx.service

:~ # rm /etc/systemd/system/novell-zislnx.service

:~ # find / -xdev -name novell-zislnx.service
/etc/systemd/system/multi-user.target.wants/novell-zislnx.service
/usr/lib/systemd/system/novell-zislnx.service

:~ # systemctl disable novell-zislnx.service
Removed symlink /etc/systemd/system/multi-user.target.wants/novell-zislnx.service.

:~ # systemctl enable novell-zislnx.service
Created symlink from /etc/systemd/system/multi-user.target.wants/novell-zislnx.service to /usr/lib/systemd/system/novell-zislnx.service.

-> Clear error and retry
zac ref

-> System Update succeeded