Hi,

zypper ps shows deleted files on imaging satellite even after restart or reboot:

zypper ps
The following running processes use deleted files:

PID | PPID | UID | User | Command | Service | Files
-----+------+-----+------+---------+--------------------------+-----------------------------------------------------------------------------------------------
3338 | 3326 | 0 | root | jsvc | novell-zenworks-xplatzmd | /opt/novell/zenworks/webserver/webapps/CasaAuthTokenSvc/WEB-INF/lib/zcmScardAuthenticate.jar
| | | | | | /opt/novell/zenworks/webserver/webapps/CasaAuthTokenSvc/WEB-INF/lib/nimbus-jose-jwt-2.10.1.jar
| | | | | | /opt/novell/zenworks/webserver/webapps/CasaAuthTokenSvc/WEB-INF/lib/xmlsec-1.4.0.jar
| | | | | | /opt/novell/zenworks/webserver/webapps/CasaAuthTokenSvc/WEB-INF/lib/json-smart-1.1.1.jar
| | | | | | /opt/novell/zenworks/webserver/webapps/CasaAuthTokenSvc/WEB-INF/lib/jcip-annotations-1.0.jar
| | | | | | /opt/novell/zenworks/webserver/webapps/CasaAuthTokenSvc/WEB-INF/lib/commons-codec-1.7.jar
| | | | | | /opt/novell/zenworks/webserver/webapps/CasaAuthTokenSvc/WEB-INF/lib/commons-logging.jar


After 'systemctl restart novell-zenworks-xplatzmd.service' or reboot the zypper reports the same files with new PIDs.

The agent runs on OES 2018; other agents on OES 2018 without the satellite role do not show the problem.

Is there an explanation for this? Is there an simple way to avoid this? (Problem is, that we are generating todo tickets if zypper sees processes using deleted files.)

Thanks,
Mirko