I'm looking into upgrading my ZCM 11 appliance to 2017 but hit a snag running ZDC 11.4.3 , lots of errors during System Files check. Not sure why there are version mismatches. Seems I have "newer" versions than what ZDC is looking for.

For example, my server has novell-zenworks-version-11.4.3.23202.msi, and zdc is looking for novell-zenworks-version-11.4.3.22434.msi


ZENworks System Files Verifier
Following required files are missing.
Severity Description
ERROR Missing file:
/etc/opt/novell/zenworks/conf/pmconfig/policyDefinitions.xml
ERROR Missing file:
/opt/novell/zenworks/bin/zenpuppet
ERROR Missing file:
/opt/novell/zenworks/bin/puppetexec
ERROR Missing file:
/opt/novell/zenworks/bin/pi
ERROR Missing file:
/opt/novell/zenworks/install/downloads/msi/novell-zenworks-version-primary-server-11.4.3.22434.msi
ERROR Missing file:
/opt/novell/zenworks/install/downloads/msi/novell-zenworks-version-11.4.3.22434.msi
ERROR Missing file:
/opt/novell/zenworks/install/downloads/msi/novell-zenworks-core-server-11.4.3.22431.msi
ERROR Missing file:
/opt/novell/zenworks/install/downloads/rpm/novell-zenworks-version-11.4.3-22434.noarch.rpm
ERROR Missing file:
/opt/novell/zenworks/install/downloads/rpm/novell-zenworks-core-server-11.4.3-22431.noarch.rpm
ERROR Missing file:
/opt/novell/zenworks/install/downloads/rpm/novell-zenworks-version-primary-server-11.4.3-22434.noarch.rpm
ERROR Missing file:
/opt/novell/zenworks/zmd/java/lib/plugins/extservicepolicy-handler.jar
ERROR Missing file:
/opt/novell/zenworks/zmd/java/lib/plugins/zpm-linux-module-props.jar
ERROR Missing file:
/opt/novell/zenworks/zmd/java/lib/plugins/policy-manager.jar
ERROR Missing file:
/opt/novell/zenworks/zmd/java/lib/plugins/puppet-handler.jar
ERROR Missing file:
/opt/novell/zenworks/zmd/java/lib/plugins/zpm-linux-module-11.4.2.601.jar
ERROR Missing file:
/opt/novell/zenworks/zmd/java/lib/plugins/policy-properties.jar
ERROR Missing file:
/opt/novell/zenworks/zmd/java/lib/plugins/policy-lib.jar
ERROR Missing file:
/etc/opt/novell/zenworks/puppet/auth.conf
ERROR Missing file:
/etc/opt/novell/zenworks/puppet/puppet.conf
ERROR Missing file:
/etc/opt/novell/zenworks/puppet/puppet.conf
ERROR Missing file:
/opt/novell/zenworks/bin/ralsh
ERROR Missing file:
/opt/novell/zenworks/bin/filebucket
ERROR Missing file:
/opt/novell/zenworks/bin/erb
ERROR Missing file:
/opt/novell/zenworks/bin/facter
ERROR Missing file:
/opt/novell/zenworks/bin/puppet
ERROR Missing file:
/opt/novell/zenworks/bin/ruby
ERROR Missing file:
/opt/novell/zenworks/bin/puppetdoc
ERROR Missing file:
/opt/novell/zenworks/bin/testrb
ERROR Missing file:
/etc/logrotate.d/novell-zenworks-puppet
Following required files are inconsistent.
Severity Description
ERROR
File '/opt/novell/zenworks/share/tomcat/conf/web.xml' is inconsistent!!!
Size: expected = 168230, actual = 167663
Checksum: expected = 3f733eeb, actual = 3416a3d6
NoSpaceChecksum: expected = 3a1d232, actual = a712398d
Owner: expected = zenworks, actual = zenworks
Group: expected = zenworks, actual = zenworks
Package name: expected = novell-zenworks-tomcat-7.0.68-1, actual = novell-zenworks-tomcat-7.0.68-1