It has the new windows moble....
I first tried to use POCKET PC 2003 Device and during the install to the
phone the phone errored saying the program tring to load was made for an
older version and errored out.

I then uninstall from pc and phone and tried to install the Pocket PC
devices and that gave me a similar error.

I was using the pdaconnect 1.0 sp1 install...

Not sure were I can go from here.