Can I assume that the version 2 client will not run against a version 1 agent?

That said, I've installed the v2 client on NLD and (when connecting to my
v1 agent, I get a message that it isn't compatible) I un-installed it by
deleting the messenger directory in the /opt/novell directory. Has GW2
been properly un-installed? When I try and install GWMSP6 it says it
updates but creates no icon nor can I found the directory it installed it into.

This may be due to the fact that all the SP files readme's state that you
must have a previous version installed first. If so, I have the CD that
came with my Small Business solution GWMSP1. Where can I get the original