Has anyone configured automatic client updating and got it to work?

I have just installed the 2.0.2 version and our clients are running the
2.0.1 client. I have followed the documentation but the client is not
prompted to update their version and when they click Help->Check for new
version they get a message saying "You are using the latest available
version". I have tried creating the website on a different web server and
pointing the Messenger service to that but with the same results. So if
anyone can suggest something, that would be great!