Fresh Netware 6.5 SP6, BM 3.9, Linkwall 3.11.0

I can't get Linkwall to work in Deny mode.

Here's my Linkwall.ncf:
#
# LinkWall ncf file
#
# Default is no logging
#
# Command line options are
#
# Log level : /log=1 - 2
# log level 1 is logging to file only
# log level 2 is logging to file and screen
#
# Log location : /logfile=<filename>
# /logfile=data:logslinkwall.log
#
# Default is sys:etclinkwalllinkwall.log
#
# Category mode : /category=on or /category=off
# /category=on Use categories defined in linkwall.lst file
# /category=off Do not use categories
#
# For example: load sys:etclinkwalllinkwall /log=2 /category=on
#
load sys:etclinkwalllinkwall /category=on


Here's a snippet of my linkwall.lst file:
#
# Sample linkwall.lst file for use with LinkWall Blacklist
# 6 May 2004
#

www.connectotel.com/linktest

$include sys:blacklistsadsurls ads
$include sys:blacklistsadsdomains ads

$include sys:blacklistsadulturls adult
$include sys:blacklistsadultdomains adult

$include sys:blacklistsaggressiveurls aggr
$include sys:blacklistsaggressivedomains aggr

$include sys:blacklistsaudio-videourls av
$include sys:blacklistsaudio-videodomains av

Now I have two rules currently in iManager:

Rule 1. All any/any to HTTP
Rule 2. I created doing New - HTTP - Deny Access - Enable Rule Hit Logging
- New URL - Type=Connectotel:LinkwallList
- Checked Category=Select from Connectotel:LinkwallList and Turn
Linkwall On

I then choose Connectotel in the Third Party URL Filtering Solution
dropdown list.

Then I click on Import Category List and choose my linkwall.lst file. It
says that it imports successfull, but nothing is ever blocked.

Any ideas?