Is it correct that starting with GMS2 sp1 there will be no longer support
for cradle based sync..??

http://www.novell.com/support/search...200%2042110492

Most of my clients are cradle based with GMS2, so it's better not to apply
sp1?