SUMMARY: evmsgui segfaults as soon as I try to run it.


I'm in the process of setting up an OES SP2 server. I have an 815 GB
hardware RAID 5 (/dev/sdb) that I want to carve up like so:

100 GB ext3 filesystem for Groupwise
500 GB NSS pool for NSS volumes
215 GB unused space

The holy grail would be a setup where I can expand/shrink the ext3
filesystem and expand/shrink (or at least expand) the NSS pool as
needed. Toward this goal, I've been experimenting with iManager and

After some false starts, I came up with this:

/dev/sdb1 - 50 GB EVMS volume formatted as ext3
/dev/sdb2 - 265 GB of free space
/dev/sdb3 - 500 GB NSS pool with an NSS volume

Graphically: |--50 GB--|+++265 GB+++|---500 GB---|
-- = used, ++ = free

Here sdb1, sdb2, and sdb3 are segments created/owned by the NWSegMgr.
This worked, and I was even able to unmount the sdb1/ext3 filesystem,
expand it to 75 GB, and remount it, preserving the data.

But as soon as I expanded the NSS pool, I ran into problems. It worked,
but the additional space was taken from the *beginning* of /dev/sdb2, so
that I could no longer expand the sdb1/ext3 filesystem.

So then I thought I'd create regions using the segments, and then
construct the ext3 filesystem and NSS pool on top of the regions. My
thinking was I could expand whichever region I needed to, then expand
the ext3 volume or NSS pool as needed.

I deleted everything on /sdb, getting back to the initial state, and
using evmsgui, I created this:

50 GB md/md0 linear region on /dev/sdb1 NWSegMgr segment
500 GB md/md1 linear region on /dev/sdb2 NWSegMgr segment
265 GB /dev/sdb2 NWSegMgr segment (unused space)

Then I was going to create the ext3 EVMS volume and, using iManager, the
NSS pool and NSS volume. Unfortunately, while setting up md/md1 (can't
quite remember exactly at which point this happened), evmsgui crashed.
Now, whenever I start it, I get a segmentation fault.

If I run it from gdb, I see it's crashing in md_restore_saved_sb():

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1078688864 (LWP 15706)]
0x4099dff6 in md_restore_saved_sb () from /lib/evms/2.3.3/
(gdb) bt
#0 0x4099dff6 in md_restore_saved_sb () from /lib/evms/2.3.3/
#1 0x40999cad in linear_plugin_function () from
#2 0x4075437f in fsim_rw_header () from /lib/evms/2.3.3/
#3 0x40756252 in nss_probe () from /lib/evms/2.3.3/
#4 0x40047ebf in find_fsim_for_volume () from /lib/
#5 0x4004a948 in get_volume_dev_node_and_fsim () from /lib/
#6 0x4004c30d in discover () from /lib/
#7 0x4004d477 in initial_discovery () from /lib/
#8 0x4005ba49 in evms_open_engine () from /lib/
#9 0x0805f757 in open_engine ()
#10 0x0805fea5 in main ()

This isn't good. Fortunately it's not in production yet, but it's not
inspiring confidence. Is this a known issue?