I am trying to use apache's mod_rewrite. Usually you uncomment the
following line in httpd:
LoadModule rewrite_module modules/mod_rewrite.so
Well, OES-Linux SP2 does not have this line. Instead, httpd refers to
another file. Here are the files and entries:
httpd file:
# generated from APACHE_MODULES in /etc/sysconfig/apache2
Include /etc/apache2/sysconfig.d/loadmodule.conf
loadmodule.conf file:
# as listed in APACHE_MODULES (/etc/sysconfig/apache2)

LoadModule rewrite_module /usr/lib/apache2-prefork/mod_rewrite.so
LoadModule suexec_module /usr/lib/apache2-prefork/mod_suexec.so
LoadModule access_module /usr/lib/apache2-prefork/mod_access.so
LoadModule actions_module /usr/lib/apache2-prefork/mod_actions.so
LoadModule alias_module /usr/lib/apache2-prefork/mod_alias.so
LoadModule auth_module /usr/lib/apache2-prefork/mod_auth.so
LoadModule auth_dbm_module /usr/lib/apache2-prefork/mod_auth_dbm.so
LoadModule autoindex_module /usr/lib/apache2-prefork/mod_autoindex.so
LoadModule cgi_module /usr/lib/apache2-prefork/mod_cgi.so
LoadModule dir_module /usr/lib/apache2-prefork/mod_dir.so
LoadModule env_module /usr/lib/apache2-prefork/mod_env.so
LoadModule expires_module /usr/lib/apache2-prefork/mod_expires.so
LoadModule include_module /usr/lib/apache2-prefork/mod_include.so
LoadModule log_config_module /usr/lib/apache2-prefork/mod_log_config.so
LoadModule mime_module /usr/lib/apache2-prefork/mod_mime.so
LoadModule negotiation_module /usr/lib/apache2-prefork/mod_negotiation.so
LoadModule setenvif_module /usr/lib/apache2-prefork/mod_setenvif.so
LoadModule userdir_module /usr/lib/apache2-prefork/mod_userdir.so
LoadModule ssl_module /usr/lib/apache2-prefork/mod_ssl.so
LoadModule php4_module /usr/lib/apache2-prefork/libphp4.so
LoadModule jk_module /usr/lib/apache2/mod_jk.so
#
Apache2 file:
# APACHE_MODULES="access actions alias asis auth autoindex cgi dir imap
include log_config mime negotiation setenvif status userdir"
# your settings
APACHE_MODULES=" rewrite suexec access actions alias auth auth_dbm
autoindex cgi dir env expires include log_config mime negotiation setenvif
userdir ssl php4 jk"
So, how do i get the mod_rewrite working?
Chris A