First off, please excuse the cross-posting of this message on two
forums, but I have seen others report the same problem I have been
having on each of these forums, but no reports of success.

I have been experiencing "error binding to eDirectory through LDAP"
when trying to install eDirectory on OES-linux. I tried:
re-install from scratch
linux only, then OES config
making sure openLDAP is not installed
making sure the LDAP ports are not in conflict
making sure edir's LDAP is listening
tried installing with different OES components
different hardware

Today I found out what was causing this problem for me:
$ (dollar sign) in the password

Apparently, OES-linux eDirectory passwords (at least for the admin,
during directory install) can not have a $ in the password. On both sets of hardware I was trying, in all the permutations I tried, I had

always been using the same admin password.

I discovered this by using a LDAP Browser/Editor
( was suggested on Novell's
site)- I was able to bind anonymously on both 389 and 636 to the OES box (after the eDirectory install error popped up, but before I opted

to cancel or retry), but was not able to authenticate. The LDAP error

given when I tried to authenticate with the cn=admin and it's
password, pointed to wrong password (Novell's TID on LDAP errors was very specific, it was wrong password, not user not found or some other


I then selected the 'clear OES settings and start over" option,
selected a very simple password and everything worked.

So don't use $ in your passwords for eDirectory on OES-linux, at least

for the initial install (while I doubt it, that may be the only time it matters). I do not know if any other characters can cause this
problem, $ was the only non-alpha numeric character I had used.

Hope this helps someone avoid some frustration