Hello All.
We have many servers with Netware 6.0 sp5 .
And we install on it Nsure Audit 1.0.2 (and some 1.0.3).
When some servers used very actively we had this abends:
Server AVALKR1 halted Thursday, February 16, 2006 12:49:42.759 pm
Abend 1 on P00: Server-5.60.05-4348: Kernel detected an attempted
context switch when it was not allowed


Registers:
CS = 0008 DS = 0010 ES = 0010 FS = 0010 GS = 0010 SS = 0010
EAX = 00000000 EBX = 00000001 ECX = 00000000 EDX = FCE23FAC
ESI = 925DA1C0 EDI = 00200246 EBP = C9006FB4 ESP = C9006F48
EIP = 002203C8 FLAGS = 00200002
002203C8 83C404 ADD ESP,00000004
EIP in SERVER.NLM at code start +00018408h

The violation occurred while processing the following instruction:
002203C8 83C404 ADD ESP,00000004
002203CB 5D POP EBP
002203CC 5E POP ESI
002203CD 5B POP EBX
002203CE C3 RET
002203CF A19447E0FC MOV EAX,[FCE04794]=FCE25BB7
002203D4 50 PUSH EAX
002203D5 E8CC7EEEFF CALL SERVER.NLM|Abend
002203DA 83C404 ADD ESP,00000004
002203DD 5D POP EBP



Running process: Server 9 Process
Thread Owned by NLM: SERVER.NLM
Stack pointer: C9006F6C
OS Stack limit: C9000040
CPU 0 (Thread C8BFC2E0) is in a NO SLEEP state
Scheduling priority: 67371008
Wait state: 5050030 Blocked on Semaphore
Stack: --FCE23FAC ?
--C9006FB4 ?
--925DA1C0 ?
--000C373B ?
0021E330 (SERVER.NLM|SchedSwitch+48)
--00000001 ?
--C9006FB4 ?
--00200246 ?
--925DA1C0 ?
--000C373B ?
0020F4F4 (SERVER.NLM|kSemaphoreWait+E0)
--C9006FB4 ?
--925EA0A0 ?
--925DA1C0 ?
--93841740 ?
80443AE2 (THREADS.NLM|_WaitOnSemaphore+26)
--925DA1C0 ?
--925DA1C0 ?
--93841740 ?
80443E13 (THREADS.NLM|WaitOnLocalSemaphore+57)
--925DA1C0 ?
--00000234 ?
--925EA0A0 ?
9251A18E (AUDITNW.NLM|(Code Start)+18E)
--925DA1C0 ?
--00000234 ?
--C900703C ?
--C9006FCC ?
9251CB5B (AUDITNW.NLM|(Code Start)+2B5B)
--925EA0A0 ?
--C900703C ?
--925DBD60 ?
--C9007010 ?
--91C0DF20 ?
80430FCC (THREADS.NLM|_DestroyCallBackBlock+260)
--C900703C ?
--00000000 ?
--00000000 ?
--C90070E4 ?
--00000002 ?
--00000001 ?
--CB05DA31 ?
8042F591 (THREADS.NLM|__CHK+21)
--925DBD60 ?
--C9006FFC ?
--00000002 ?
--00000001 ?
--CB05DA31 ?
--C90070E4 ?
CB27C66D (LFS.NLM|FSMonitorExit+25)
--C900703C ?
--00000000 ?
--00000000 ?
--00000002 ?
--00000001 ?
--CB05DA31 ?
--C90070E4 ?
--00000000 ?
--9239F060 ?
CB27D9B4 (LFS.NLM|F3OpenCreateEx+B7)
CFD89A0E (NCP.NLM|Case87+152)
--00000030 ?
--00000001 ?
--00000002 ?
--00000001 ?
-0013B729 (LOADER.EXE|SendSpurIntToRealMode+22F1)
--CB05DA75 ?
--00000004 ?
--00000000 ?
--00000001 ?
--00000006 ?
--00000000 ?
--00000003 ?
--0000018C ?
--825971C0 ?
--825971C4 ?
--825971C6 ?
--82597212 ?
--C90070A8 ?
--00000000 ?
--C90079AC ?
--C90070F0 ?
CB68323C (NWSA.NSS|NWSA_SetupNameMsgFromHandlePath+7C)
--C9007BC0 ?
--CB05DA75 ?
--00000004 ?
--00000001 ?
--00000003 ?
--0000004C ?
-0013B729 (LOADER.EXE|SendSpurIntToRealMode+22F1)
--825971C0 ?
--C9007124 ?
--00000002 ?
--878C508C ?
--0000018C ?
--00000000 ?
--00000000 ?
--878C508C ?
--C90074C4 ?
--0000001B ?

Additional Information:
The NetWare OS detected a problem with the system while executing a
process owned by SERVER.NLM. It may be the source of the problem or
there may have been a memory corruption.



It's very stable abend :-( on many of our servers.

Can anyone help us?

P.S. Sorry for bad English.